您的位置:知识库 » 编程语言

Eclipse和PyDev搭建完美Python开发环境(Windows篇)

作者: Realh  来源: 博客园  发布时间: 2010-11-23 17:10  阅读: 68833 次  推荐: 3   原文链接   [收藏]  
摘要:本文讲解了用Eclipse和PyDev搭建Python的开发环境。

  十一长假在家闲着没事儿,准备花点时间学习一下Python。 今儿花了一个下午搭建Python的开发环境,不禁感叹————开源的东西就是麻烦啊··· 唉,可怜我们这些被微软宠坏了的开发人员···

  为什么不用别的IDE呢?

  IDLE是小打小闹用的,那个WingIDE是要钱的,而且用不惯。Eclipse+PyDev插件是最主流的Python开发环境了。

  1.准备工作

  下载32位的JDK6 Java的开发包  我也不想装这玩意儿,但是Eclipse依赖他,没办法。

  下载32位的Eclipse (注1)

  下载Python 2.x (注2)

  2.安装JDK6

  JDK的安装很容易的,一般一直点下一步即可. 多数教程都说,安装完JDK需要设置环境变量,但如今的IDE已经不再通过环境变量来查找JDK的路径了,所以这个不设也罢。 

  3.安装Eclipse和Python

  Eclipse是绿色软件,找个地方解压一下就OK了 。Python的安装就更不用说了

  4.给Eclipse安装PyDev插件

  启用Eclipse————如果前面的步骤都正确无误的话,那么Eclipse就该能够正常启动了。 第一次启动会让你选择一个工作空间,按缺省设置,勾选一下不再提醒,就可以了。

  在Help菜单中,选择Install New Software···, 选择Add按钮,Name:PyDev(这个随便起),Location:http://pydev.org/updates(PyDev的更新地址),OK

EclipseAndPyDev(Windows)_AddRepository

  选择PyDev下的PyDev for Eclipse,别的都不要选,否则依赖检查那关过不去。

EclipseAndPyDev(Windows)_InstallDialog  点下一步,下一步安装。中间会问你是否信任Aptana、Pydev什么的,信任就可以了。

  最后重启Eclipse

  5.配置PyDev插件

  在Window菜单中选Preference,

  1、PyDev->Interpreter - Python,New一个Python解释器,填上解释器名字和路径,路径选相应的python.exe。
EclipseAndPyDev(Windows)_SelectInterpreter
EclipseAndPyDev(Windows)_SelectNeeded

  以下几步Python 3.x必选,Python 2随意。我比较习惯Unicode,所以一次性在这儿设定了。

  2、General->Editors->Text Editors->Spelling,Encoding改成Other:UTF-8

  3、General->Workspace,Text file encoding改成Other:UTF-8

  4、找到安装目录下的\plugins\org.python.pydev.debug_x.x.x.yyyymmddhh\pysrc\pydevd.py,

  920行的 encoding = Non 改成 encoding = "UTF-8",保存

  至此,PyDev的配置就完成了。

  6.测试下

  File->New->Project,选PyDev下的PyDev Project,Grammer和Interpreter选相应的版本,Finish。
EclipseAndPyDev(Windows)_CreatePyDevProject

  在PyDev Package Explorer的项目上右键,New->PyDev Module,随便写个名字,Finish。

  然后随便写几行代码,Run

  在弹出的对话框中选择Python Run ,

  OK
EclipseAndPyDev(Windows)_Result

  注释:
  注1:这里说明一下,JDK和Eclispse好像得同为32位或者64位的,否则有可能遇到问题。我第一次尝试是用的64位JDK+32位Eclipse的组合,就碰到了和这里http://superuser.com/questions/186001/eclipse-failed-to-load-the-jni-shared-library一样的问题,于是果断换了32位JDK。

  注2:我想做GAE的开发,所以选了版本2.6.6,一般情况下选最新版即可。

  注3:PyDev Mylyn Integration (optional):这个依赖于PyDev for Eclipse,你得装完后者就可以装了。 PyDev Django Templates Editor:这个需要Aptana Studio 3。

3
0

编程语言热门文章

    编程语言最新文章

      最新新闻

        热门新闻